Jump to content

PC becomes extremely slow and the game stops responding.


Recommended Posts


I have a very strange bug. After playing for a few minutes or sometimes hours. The game starts to get extremely slow and stops responding. This also affects my computer until I restart it. The problem persists even if I close PRO.

Strange that I don't have this problem for other games or heavier games like CS2, Escape From Tarkov, etc...

I've checked the Windows logs and haven't found any reports that could be useful, so I'll keep monitoring.

CPU : AMD Ryzen™ 9 7900X
Motherboard : ROG CROSSHAIR X670E HERO
GPU : ROG Strix GeForce RTX® 4090 OC Edition 24GB GDDR6X
Cooler : Alphacool Eisbaer 240(Custom)
Thermal Paste:Cooler Master Mastergel Maker
RAM : 32gb G.SKILL 6000mhz(2x F5-6000J3038F16GX2-TZ5NR)
Power Supply : Corsair HX1000 80 Plus Platinum Modular
SSD : 870 EVO Samsung V-NAND 500GB (RAID 0)
SSD : 870 EVO Samsung V-NAND 500GB (RAID 0)
SSD : 870 EVO Samsung V-NAND 500GB (RAID 0)
SSD : 870 EVO Samsung V-NAND 500GB (RAID 0)
NVMe: Asgard 1tb
NVMe: WD SN750 2tb
External Storage: Samsung T5 Blue 500gb
Backup Cooler: DeepCool Assassin II

Windows 11

Monitor : ALIENWARE 27” QHD AW2723DF
Monitor 2 : ROG Strix 17" XG17AHP


Link to comment
Share on other sites

If you have VSync disabled, make sure to set a FPS limit. If it is uncapped, the game will try to render as many frames as possible, which may use an excessive amount of resources, resulting in the poor performance.



Edited by Deita
Link to comment
Share on other sites

  • Administrator
On 11/2/2023 at 2:45 PM, Fehedu said:

Vsync was already activated, I will continue monitoring and try to find something that could perhaps be the trigger for the problem.

If I find the cause or a solution I will share it in this topic.



Hello there @Fehedu


I'm sorry to hear about the issue you are experiencing. Unfortunately, this is a very rare issue that is 1 person on a 10.000 experience, so it's not easy to find what causes it.

Could you perhaps try to:

  • Disable the V-Synch and play with it disbled for a while and see if you keep experiencing this issue
  • Try to switch from Fullscreen to Windowed and back to Fullscreen.


I also suggest you to check the NVIDIA Panel Control, 3D Settings, to see if you have changed them somehow and therefore might conflict with PRO. If you did, maybe try as well, together with the V-Synch, to restore them to default.


Let me know if you still encounter the issue.




Please do not contact staff members for private support

Share your questions on the forums as they could be useful to others

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...