• Welcome to Pokemon Revolution Online. You're currently visiting as a guest. Sign up or log in to access the whole forum and start discussions!

PRO black screen / "Failed to load mono"

Jilan

Newbie Trainer
Joined
May 16, 2017
Messages
76
Total likes
9
Age
27
Location
France
Hi everyone

so earlier today, i had black screen when starting pro, like everyone i tried to reboot, and i tried the solution given by the forum :



didnt work, so i tried to delete my folder and reinstall PRO, but here is what i had :




then i finally went to the (amazing) support section on discord, and we have found the issue :

Because of the last windows update, Microsoft security essential and Windows defender (respectively on windows 7 and 10)

both see one of the files in the new PRO folder as a threat, and delete it/put i in quarantaine, obviously, its a false positive

Again, thanks to the support channel on discord, we manage to find a solution for w7 & w10 :

1: Delete your pro files
2: Disable Microsoft security essential (for w7) / or Windows Defender (for w10)
3: Unzip PRO current version again
4: Add the whole PRO folder to the "exclusion list" of Microsoft Security Essential (for w7) / or Windows Defender (for w10)
5: Enable Microsoft security essential / Windows Defender

Make sure you followed all thoses steps !

edit1 : solution for both windows 7 & windows 10 below, keep scrolling if you are a w10 user !
edit2* : for users who have some issues with how to disable windows defender, i added some more informations about it at the end, keep scrolling !
edit3**: download the win x32 bit version and let us know if you still have issues , feedback needed here, thanks !

If you have windows 7 like me, the problem is the same but with Microsft Security Essential (MSE), you have to delete pro, disable MSE, unzip PRO again, then add the folder to the "exclusion list" :

here is how you disable MSE on w7:



And once you unzip PRO again, this is how you add your files to the exclusion list :










If you have windows 10, you need to disable windows defender, unzip PRO again, and add the folder to the "exclusion list" of windows defender, then enable it :







Virus & Threat Protection Settings :



Scroll down, Add or Remove, exclusions :



Add a Folder :



Then Select your whole folder :



Then open the game !

edit2* : Thanks to your feedback on discord, i add more helpfull screen & link about w10/windows defender :



https://support.microsoft.com/en-us/help/4027187/windows-turn-off-windows-defender-antivirus

this works also just abit differently

settings > windows defender >open security center >virus >protection settings>controlled folder (on) >protected folder choose the PRO64 or PRO32 (delete old files and then re extract and it should work)



Download the x32 version might be an easier fix for now, if it works for everyone.

the file considerer as a threat by windows defender & Microsoft security essential may be only in the x64 version, if anyone can confirm (or not) let us know !


Since i dont have w10 myself so i had to ask some kind people to send me the screens, but really you should find it quite easily
If you still have issues, ask for help here on in discord support channel, and lets talk about it !


And of course big thanks to thoses guys in support channel on discord : Olaf, Braj, Akathepriest, sobhi, monhuntress, furtif k, and im sure i forgot some, thanks for the help !

Edit : Huge thanks to sobhi for thoses windows 10 screens !
let me know if something isnt crystal clear, i'll change it ! thanks !
 
Last edited:

onkar

Junior Trainer
Joined
Oct 24, 2016
Messages
274
Total likes
23
Age
20
Location
India
Thanks a lot buddy! you just solved my problem! :SquirtleSquad::GalladeDab:
 

Astreus

Former Staff
Former Staff
Joined
Jan 15, 2018
Messages
354
Total likes
26
Location
Astra Planeta
Hi there Jilan,

Thank you for making a guide on how to fix the black screen issues. We really appreciate it. I've moved this to the proper subforum which is the Non-content Guides since the one that you posted in is actually a subforum to report any kind of bugs about the game. With that being said, I wish you a good day!

Best regards,
Astreus.
 

Jilan

Newbie Trainer
Joined
May 16, 2017
Messages
76
Total likes
9
Age
27
Location
France
Hello there,

Honestly its really thanks to the support channel on discord, they fixed it and i just wrote it on forum since we are many to have an issue with !

Thanks for the move thing, i'll be more carefull next time !
 

Saphirr

Former Staff
Former Staff
Joined
May 29, 2017
Messages
2,071
Total likes
11
Location
France
Thank you for your guide. I feel like many players will be needing this such as I did. Best of luck to you in game also.
 

monhuntress

Rookie Trainer
Donator
Joined
Aug 14, 2016
Messages
130
Total likes
8
this works also just abit differently

settings > windows defender >open security center >virus >protection settings>controlled folder (on) >protected folder choose the PRO64 or PRO32 (delete old files and then re extract and it should work)
 

Ridora

Youngster
Joined
Mar 12, 2018
Messages
7
Total likes
2
Hello, I am French but I use google translation to communicate ^^ Here is my question: is it really necessary to disable the antivirus? Before the arrival of the new client, everything was simpler, faster, using an object or entering a building was very fast and without desactivating the antivirus but today ... I followed this guide step by step, I can play but .. now, ride a bike, enter a building, meet a pokemon, talk to an NPC, all my actions require 1 second before they are executed! It has become slower and when I have reactivated the antivirus = Failed to load mono, and I have to re-download everything from the beginning.
 
Last edited:

Jilan

Newbie Trainer
Joined
May 16, 2017
Messages
76
Total likes
9
Age
27
Location
France
Hello, I am French but I use google translation to communicate ^^ Here is my question: is it really necessary to disable the antivirus? Before the arrival of the new client, everything was simpler, faster, using an object or entering a building was very fast and without desactivating the antivirus but today ... I followed this guide step by step, I can play but .. now, ride a bike, enter a building, meet a pokemon, talk to an NPC, all my actions require 1 second before they are executed! It has become slower and when I have reactivated the antivirus = Failed to load mono, and I have to re-download everything from the beginning.
If you want me to translate in french, i can do that, just ask (i dont think we are allowed to speak anything else but english here, but i can manage a spoil, pm or something)

I cant say for sure but i dont think thoses " 1 seconde delay " while changing map & riding bike, etc .. are due to the new launcher, i had thoses sames things during the servers crash a few weeks ago, and that was before the update.

btw, if you did follow the tutorial step by step you shouldnt have "failed to load mono" when you reactive your firewall, that's one of the major point of this.
i think you missed the part when you add PRO to your "exclusion list" on MSE/WD, depending on your explotation system, W7 or W10
once its done you can run PRO with MSE or WD active, same goes for your firewall


Great guide!
Thanks to you !

this works also just abit differently

settings > windows defender >open security center >virus >protection settings>controlled folder (on) >protected folder choose the PRO64 or PRO32 (delete old files and then re extract and it should work)
thanks, added to main post !
 
Top